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See also main SDK page.

AEE - Introduction

In this example we will show how to create custom administration page.
what will be shown in the example

1. how to create custom administration page
2. how to register custom administration page to Polarion

AEE - Java APl Workspace preparation
See section Workspace preparation

AEE - Creating project plugin

The best way is to import provided example, which contains all dependencies you need for custom plugin creation

AEE - Import of the example

Info: You must ensure that your plugin is compiled against your Polarion version. This example contains precompiled jar plugin. You can remove it before you start developing your plugin
based on this example. The Eclipse ensure that new jar plugin will be created against your source code and Polarion version.

To import this example to workspace, do these steps:

1. Select File > Import...

2. In the dialog that appears, select Existing Project into Workspace in General section and press Next button.

3. By pressing Browse.. button, select the directory of examples (mostly in C: \Polarion\polarion\SDK\examples\). Submit it.
4. Select com.polarion.example.administration and press Finish.

AEE - Deployment to Installed Polarion
See section Deployment to Installed Polarion

AEE - Execution from Workspace
See section Execution from Workspace

AEE - Configuration

Custom administration pages are registered via hivemodule.xml to contribution with id com.polarion.xray.webui.administrationPageExtenders.

Extender attributes: id (required), name, iconUrl, pageUrl, parentNodeld, parentNodeName, parentNodelconUrl, projectScope (Boolean), projectGroupScope (Boolean), repositoryScope
(Boolean)

<?xml version="1.0" encoding="UTF-8"2>

<module id="com.polarion.example.administration” version="1.0.0">
<contribution configuration-id="com.polarion.xray.webui.administrationPageExtenders">
<extender id="administrationExample"
parentNodeId="administrationExampleFolder"
name="Page" parentNodeName="Example"
parentNodeIconUrl="/polarion/icons/default/topicIcons/Tools_157-wrench.png"
iconUrl="/polarion/icons/default/topicIconsSmall/Tools_
pageUrl="/polarion/administrationExample/administration.jsp?s
projectScope="true" projectGroupScope="true" repositoryScoj
</contribution>
</module>

Requirements

Development Environments

¢ Eclipse IDE for Enterprise Java Developers or any other Eclipse IDE with The Eclipse Plug-in Development Environment. (Go to Help > Install New Software... > Install Eclipse Plug-in
Development Environment > Restart Eclipse)
o Eclipse Temurin™ 17 (LTS) by Adoptium for building and running your code.

Workspace Preparation
To start developing a Polarion Java API plug-in, you first need to perform following steps:

. Start Eclipse, then select Window > Preferences...

In the dialog that appears, select Plug-In Development > Target Platform.

Click the Add button on the right.

Keep the Nothing: Start with an empty target definition option selected and click Next.
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Create a new target definition.
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Initialize the target definition with:

© Nothing: Start with an empty target definition
(0) Default: Default target for the running platform
(O) Current Target: Copy settings from the current target platform

O Template: Base RCP (Binary Only)
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Figure WP-1: Starting with an Empty Target Definition

5. Enter a Name and click Add.
6. Select Directory and click Next.
7. Click Browse and select the C:\Polarion\polarion folder (Windows) or /opt/polarion/polarion (Linux). (One level above the plugins folder.)
8. Click Next.
| & Add Content [}

Preview Contents

The plug-ins found in the container are visible below

Plug-ins:

= com.polarion.synchronizer.proxy.palarion

<= com.polarion.synchronizer.proxy.reqif
<= com.polarion.synchronizer.ui

<= com.polarion.synchronizer (3.

<= com.polarion.usdp.persistence (
<= com.siemens.plm.bitools.analytic:

< com.siemens.polarion.ct.collectors.git (2

< com.siemens.polarion.eclipse.configurator

<= com.siemens.polarion.integration. ci
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Figure WP-2: Currently Installed Polarion Plug-ins
9. Alist of currently installed Polarion plug-ins appears. Click Finish.

Target Content >
Edit the name, description, and plug-ins contained in a target. @
hd

MName: Polarion

Locations Content  Envirenment Arguments  Implicit Dependencies

The following list of locations will be used to collect plug-ins for this target definition.

(= C\Polarien\polarion 295 plug-ins available Add...
Edit...
Remove
Update

Refresh

Expand All

[C) Show lecatien content

Figure WP-3: Confirm the Selected Path
10. The selected path and the number of discovered plug-ins available appear. Confirm that the path is correct and click Finish.{WP_4.png|description=Figure WP-4: Select the Target
Platform}
11. Check the box beside the newly added path and click Apply.

Deployment to Installed Polarion

You can deploy a plugin to Polarion in two ways. First you can export a project as Deployable Plugins and Fragments. The second way is described in the following section Execution from
Workspace. To export the plug-in, perform these steps:

1. Select File > Export...

2. In the dialog that appears, select Deployable Plugins and Fragments in Plug-in Development section and click the Next button.

3. Mark your project (e.g. for Servlet example it will be com.polarion.example.servlet), and as the destination directory specify the polarion folder of your Polarion installation
directory (usually in C: \Polarion\polarion)

4. Atthe Options card be sure, that Package plug-ins as individual JAR archives is unchecked. Click Finish.

5. Because this is a new polarion plug-in extension, you have to restart your Polarion server.

NOTE: Servlets loaded by Polarion are cached in: [Polarion Home]\data\workspace\.config. If this folder is not deleted before deploying a servlet extension (plugin) and restarting
Polarion, then either the servlets will not be properly loaded, or the old ones will be loaded.

Execution from Workspace

The second way to deploy the plug-in to Polarion is to launch Polarion directly from your Eclipse workspace. This method has the added advantage of debugging the code directly in Eclipse.

1. Select Run > Open Debug Configurations..
2. Create a new Eclipse application (double click on Eclipse Application)
3. You should set:

O
Create, manage, and run configurations

Create a configuration to launch an Eclipse application in debug mode.

B @R %|B T~ | Name PolarionServer
type filter text Main | 4= Arguments | “§ Plug-ins | [~ Configuration| (= Tracing | B Environment | ] Common | [P| Prototype
v & Eclipse Application Workspace Data

S New_configuration Location: C:\Polarion\data\workspace

@ Gradle Test

B0 Java Applet [ Clear: workspace log only Workspace... File System... Variables...

[T Java Application Ask for confirmation before clearing Configure defaults...

Ju JUnit

JU JUnit Plug-in Test Program to Run

5 Launch Group Run a product: 4 org.eclipse.platform.ide

“h NSRI Frameunel



W o

T, Remote Java Applicstion © Run 2n application:  com.polarion.core.boot.app v

Filter matched 10 of 10 items

Java Runtime Environment

Java executable: © Default {javaw) (@] java
(O Execution environment:  CDC-1.0/Foundation-1.0 (jre-17.0.6) Environments...
© Runtime JRE: jre-17.0.6 ~ Installed JREs...

Bootstrap entries:

Show Command Line Revert Apply

@

Figure EXEC-1: Debug - Main page

e Nameto Polarion Server
* Workspace Data Location to C: \Polarion\data\workspace (assuming that your Polarion is installed in C: \Polarion\).
« Run an application to com.polarion.core.boot.app in the Program to Run section.

4. Finally set your Runtime JRE. On the second, "Arguments" tab, set the following arguments:

In the Program Arguments section:

Windows:

-0s win32 -ws win32 -arch x86 -appld polarion.server

Linux:

~o0s linux -ws gtk -arch x86_64 -appId polarion.server

In the VM Arguments section:

Windows:

~Xmslg -Xmxlg

~Dcom. polarion.home=

\Polarion\polarion

-XX:+UseBiasedLocking -XX:BiasedLockingStartupDelay=0

--add-opens=java.
.base/java.lang.invoke

--add-open

--add-opens=java.
.base/java.net.spi=ALL-UNNAMED --add-opens=java.base/java.nio=ALL-UNNAMED --add-opens=java.base/java.nio.channels=ALL-UNNAMED
.base/java.nio.channels.spi=ALL-UNNAMED --add-opens=java.base/java.nio.charset:

--add-open:
~-add-open:

--add-opens=java.
--add-opens=java.
.base/java.security.spec=ALL-UNNAMED --add-opens=java.base/java.text=ALL-UNNAMED --add-opens=java.base/java.text.spi=ALL-UNNAMED

--add-open

--add-opens=java.
--add-opens-java
~-add-open:

--add-opens=java.
--add-opens=java
--add-open
—-add-open:
--add-open:

~-add-open:
--add-open:

--add-open:
~-add-opens
--add-open:

Linux

~Xmslg -Xmxlg

.base/sun.nio.fs=ALL-UNNAMED --add-open:
.desktop/java.applet=ALL-UNNAMED --add-opens=java.desktop/java.awt=ALL-UNNAMED --add-open
.desktop/java.awt.desktop=ALL-UNNAMED --add-open.
.desktop/java.awt.even
.desktop/java.awt
--add-opens=java.
--add-opens=java.
--add-opens=java.
.desktop/sun.awt=ALL-UNNAMED --add-opens
.instrument/java.lang.instrument=ALL-UNNAMED
.prefs/java.util.prefs=ALL-UNNAMED --add-opens
--add-opens=java.
--add-opens=java.
--add-opens=java.

base/java.io=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.lang.annotation=ALL-UNNAMED
LL-UNNAMED --add-opens=java.base/java.lang.module=ALL-UNNAMED --add-opens=java.base/java.lang.ref=ALL-UNNAMED
base/java.lang.reflect=ALL-UNNAMED --add-opens=java.base/java.math=ALL-UNNAMED --add-opens=java.base/java.net=ALL-UNNAMED

LL-UNNAMED --add-opens=java.base/java.nio.charset.spi=ALL-UNNAMED
base/java.nio.file=ALL-UNNAMED --add-opens=java.base/java.nio.file.attribute=ALL-UNNAMED add-opens=java.base/java.nio.file.spi=ALL-UNNAMED
base/java.security=ALL-UNNAMED --add-opens=java.base/java.security.cert=ALL-UNNAMED --add-opens=java.base/java.security.interfaces=ALL-UNNAMED

base/java.time=ALL-UNNAMED --add-opens=java.base/java.time.chrono=ALL-UNNAMED --add-opens=java.base/java.time.format=ALL-UNNAMED

.base/java.time.temporal=ALL-UNNAMED --add-opens=java.base/java.time.zone=ALL-UNNAMED --add-opens=java.base/java.util=ALL-UNNAMED
.base/java.util.concurren

ALL-UNNAMED --add-opens=java.base/java.util.concurrent.atomic=ALL-UNNAMED --add-opens=java.base/java.util.concurrent.locks=ALL-UNNAMED:
base/java.util.function=ALL-UNNAMED --add-opens=java.base/java.util.jar=ALL-UNNAMED --add-opens=java.base/java.util.regex=ALL-UNNAMED

.base/java.util.spi=ALL-UNNAMED --add-opens=java.base/java.util.stream=ALL-UNNAMED --add-opens=java.base/java.util.zip=ALL-UNNAMED

ava.datatransfer/java.awt.datatransfer=ALL-UNNAMED
java.desktop/java.awt.color=ALL-UNNAMED
ava.desktop/java.awt.dnd=ALL-UNNAMED --add-opens=java.desktop/java.awt.dnd.peer=ALL-UNNAMED

LL-UNNAMED --add-opens=java.desktop/java.awt.font=ALL-UNNAMED --add-opens=java.desktop/java.awt.geom=ALL-UNNAMED

im=ALL-UNNAMED --add-opens=java.desktop/java.awt.im.spi=ALL-UNNAMED --add-opens=java.desktop/java.awt.image=ALL-UNNAMED
desktop/java.awt.image.renderable=ALL-UNNAMED --add-opens=java.desktop/java.awt.peer=ALL-UNNAMED --add-opens=java.desktop/java.awt.print=ALL-UNNAMED
desktop/java.beans=ALL-UNNAMED --add-opens=java.desktop/java.beans.beancontext=ALL-UNNAMED --add-opens=java.desktop/javax.swing=ALL-UNNAMED
desktop/javax.swing.border=ALL-UNNAMED --add-opens=java.desktop/javax.swing.text=ALL-UNNAMED --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED
java.desktop/sun.font=ALL-UNNAMED --add-opens=java.desktop/sun.java2d=ALL-UNNAMED :
add-opens=java.logging/java.util.logging=ALL-UNNAMED --add-opens=java.management/java.lang.management=ALL-UNNAMED :
ava.rmi/java.rmi=ALL-UNNAMED --add-opens=java.rmi/java.rmi.dgc=ALL-UNNAMED :
rmi/java.rmi.registry=ALL-UNNAMED --add-opens=java.rmi/java.rmi.server=ALL-UNNAMED --add-opens=java.sqgl/java.sql=ALL-UNNAMED
xml/com.sun.org.apache.xerces.internal.dom=ALL-UNNAMED --add-opens=java.xml/com.sun.org.apache.xerces.internal.jaxp=ALL-UNNAMED
xml/com.sun.org.apache.xerces.internal.parsers=ALL-UNNAMED --add-opens=java.xml/com.sun.org.apache.xerces.internal.util=ALL-UNNAMED

java.base/sun.security.ss1=ALL-UNNAMED --add-open.

~Dcom.polarion.home=/opt/polarion/polarion -Dcom.polarion.propertyFile=/opt/polarion/etc/polarion.properties
-XX:+UseBiasedLocking -XX:BiasedLockingStartupDelay=0

--add-opens=java.
.base/java.lang.invoke

--add-open

--add-opens=java.
—-add-opens=java.
.base/java.nio.channels.spi=ALL-UNNAMED --add-opens=java.base/java.nio.charset=ALL-UNNAMED --add-opens=java.base/java.nio.charset.spi
.base/java.nio.file=ALL-UNNAMED --add-opens=java.base/java.nio.file.attribute=ALL-UNNAMED
.base/java.security=ALL-UNNAMED --add-opens=java.base/java.security.cert=ALL-UNNAMED --add-opens=java.base/java.security.interfaces=ALL-UNNAMED
.base/java.security.spec=ALL-UNNAMED --add-opens=java.base/java.text=ALL-UNNAMED --add-opens=java.base/java.text.spi=ALL-UNNAMED

java.
.base/java.time.temporal=ALL-UNNAMED --add-opens=java.base/java.time.zone=ALL-UNNAMED --add-opens=java.base/java.util=ALL-UNNAMED
.base/java.util.
.base/java.util.
.base/java.util.spi=ALL-UNNAMED --add-opens=java.base/java.util.stream=ALL-UNNAMED --add-opens=java.base/java.util.zip=ALL-UNNAMED
.base/sun.nio.fs=ALL-UNNAMED --add-open:
java.
—-add-opens=java.
.desktop/java.awt.even
.desktop/java.awt.im=ALL-UNNAMED --add-opens=java.desktop/java.awt.im.sp.
.desktop/java.awt.image.renderable=ALL-UNNAMED --add-opens=java.desktop/java.awt.peer=ALL-UNNAMED --add-opens=java.desktop/java.awt.print=ALL-UNNAMED
~-add-opens=java.
--add-opens=java.
—-add-opens=java.
—-add-opens=java.
.prefs/java.util.prefs=ALL-UNNAMED --add-open
.rmi/java.rmi.registry=ALL-UNNAMED --add-open
—-add-opens=java.
--add-opens=java.

~-add-open:

~-add-open:
--add-open
--add-open
--add-opens=java
~-add-open:
~-add-open!
~-add-open:
--add-open
--add-open

--add-open
--add-open
--add-open

~-add-open
--add-open

base/java.io=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.lang.annotation=ALL-UNNAMED
LL-UNNAMED --add-opens=java.base/java.lang.module=ALL-UNNAMED --add-opens=java.base/java.lang.ref=ALL-UNNAMED
base/java.lang.reflect=ALL-UNNAMED --add-opens=java.base/java.math=ALL-UNNAMED --add-opens=java.base/java.net=ALL-UNNAMED
base/java.net.spi=ALL-UNNAMED --add-opens=java.base/java.nio=ALL-UNNAMED --add-opens=java.base/java.nio.channels=ALL-UNNAMED

LL-UNNAMED
add-opens=java.base/java.nio.file.spi=ALL-UNNAMED

base/java.time=ALL-UNNAMED --add-opens=java.base/java.time.chrono=ALL-UNNAMED --add-opens=java.base/java.time.format=ALL-UNNAMED

ALL-UNNAMED --add-opens=java.base/java.util.concurrent.atomic=ALL-UNNAMED --add-opens=java.base/java.util.concurrent.locks=ALL-UNNAMED;
LL-UNNAMED --add-opens=java.base/java.util.jar=ALL-UNNAMED --add-opens=java.base/java.util.regex=ALL-UNNAMED

java.base/sun.security.ssl=ALL-UNNAMED --add-open ava.datatransfer/java.awt.datatransfer=ALL-UNNAMED
desktop/java.applet=ALL-UNNAMED --add-opens=java.desktop/java.awt=ALL-UNNAMED --add-opens=java.desktop/java.awt.color=ALL-UNNAMED
desktop/java.awt.desktop=ALL-UNNAMED --add-opens=java.desktop/java.awt.dnd=ALL-UNNAMED --add-opens=java.desktop/java.awt.dnd.peer=ALL-UNNAMED
LL-UNNAMED --add-opens=java.desktop/java.awt.font=ALL-UNNAMED --add-opens=java.desktop/java.awt.geom=ALL-UNNAMED
LL-UNNAMED --add-opens=java.desktop/java.awt.image=ALL-UNNAMED

desktop/java.beans=ALL-UNNAMED --add-opens=java.desktop/java.beans.beancontext=ALL-UNNAMED --add-opens=java.desktop/javax.swing=ALL-UNNAMED
desktop/javax.swing.border=ALL-UNNAMED --add-opens=java.desktop/javax.swing.text=ALL-UNNAMED --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED
desktop/sun.awt=ALL-UNNAMED --add-opens=java.desktop/sun.font=ALL-UNNAMED --add-opens=java.desktop/sun.java2d=ALL-UNNAMED :
instrument/java.lang.instrument=ALL-UNNAMED --add-opens=java.logging/java.util.logging=ALL-UNNAMED --add-opens=java.management/java.lang.management=ALL-UNNAMED :
ava.rmi/java.rmi=ALL-UNNAMED --add-opens=java.rmi/java.rmi.dgc=ALL-UNNAMED :
java.rmi/java.rmi.server=ALL-UNNAMED --add-opens=java.sql/java.sql=ALL-UNNAMED
xml/com.sun.org.apache.xerces.internal.dom=ALL-UNNAMED --add-opens=java.xml/com.sun.org.apache.xerces.internal.jaxp=ALL-UNNAMED
xml/com.sun.org.apache.xerces.internal.parsers=ALL-UNNAMED --add-opens=java.xml/com.sun.org.apache.xerces.internal.util=ALL-UNNAMED

5. You must now change the parameters to the Polarion server based on your installation. You can check the settings with the following screenshot:

& Debug Configurations m] X

Create, manage.

and run configurations

Create a configuration te launch an Eclipse application in debug mode,




O#@dB xl BV~ Name: Polarion Server

type filter text =] Main | 4= Arguments| “§ Plug-ins

Configuration‘ Tracing‘ s Environment‘ i=] Commonl (B Prototypa‘

w & Eclipse Application
= New_configuration
@ Gradle Test
Java Applet
Java Application
Ju JUnit
- .
Ju JUnit Plug-in Test

Program arguments:

-0s win32 -ws win32 -arch x86 -appld polarion.server a

v

@ Launch Group
4 05Gi Framework

[T Remote Java Application VM arguments:

-¥ms236m -Xmx640m

-¥X:+UseBiasedLocking
-XX:BiasedLockingStartupDelay=0

Variables...

-Dcom.polarion.home=C:\Polarion'polarion

--add-opens=java.basefjava.io=ALL-UNNAMED
--add-opens=java.basefjava.lang=ALL-UNNAMED

—-add-nnenc—iaua hasefiava lann annntatinn— A1 | -1 INNAMED
Variables...
B Use the -XX:+ ShowCodeDetailsInExceptionMessages argument when launching
([ Use @argfile when launching
Working directory:
O Default: CAWINDOWS\system32
(O Other:
Waorkspace... File System... Variables...
. Show Command Line Revert Apply
Filter matched 10 of 10 items
@

Figure EXEC-2: Debug - Arguments page
6. On the third "Plug-ins" tab, make sure, you have also selected "Target Platform" plugins.

7. Select all, and then click the Validate Plug-ins button. If there are some problems, uncheck the plugins which are in conflict.

MName: Polarion Server

[E] Main | pa= Argumnents |3 Plug-ins|

Conf\gurationl Tracing‘ m Environment‘ = Commonl el Prototype‘

Launch with: Plug-ins selected below

Default Start level:

type filter text

Plug-ins
> @ Ou Workspace
~ @ ¥| Target Platform
B % antlr 27.7)
B ¥ antlird (3.5.3)
8 %= antld-runtime (4.5.3)
B %= bepkix (1.72.0)
B %= beprov (1.72.0)
B % beutil (1.72.0)
B %= checker-qual (3.12.0)
.:tk com.auth0java-jwt (3.11.0)
°=D" com.fastereml.classmate (1.3.0)
.!'abz com.fasteremljackson (2.13.4)
."abz com.fastencmljackson.annotations (2,14.2)
'3'01: com.fastereml jackson.core (2.14.2)
n%rrs com.fastereml jackson.databind (2.14.2)
M % com fasteremliackson.dataformat xml (2.14.71

[ Include required Plug-ins automatically while launching
B Include optional dependencies when computing required Plug-ins

B Add new workspace Plug-ins to this launch configuration automatically

B Validate Plug-ins automatically prior to launching

Default Auto-Start: false
Select All
Start Level Auto-Start Deselect All
Select Working Set...
default default Select Required
default default
default default Restore Defaults

default default
default default
default default
default default
default default
default default
default default
default default
default default
default default

Aefanl el 1 Only show selected

298 out of 302 selected

Validate Plug-ins

Show Command Line

Revert Apply

Figure EXEC-3: Debug - Plug-ins page
8. Other pages shouldn't be changed. Just click the Debug button, and go on with your new Polarion Server application.




